package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))`)
var str = `-5.0x^5 + 20x^4 +x^3 + x +2
5*x^4 + 2.5*x + 3`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}