re = /[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]/
str = 'This operation bla bla bla...
// Closing marks
Confirm this command? [YES,no]
Confirm this command? (YES,no)
Confirm this command? <YES,no>
// YES,NO
Confirm this command? [YES,no]
Confirm this command? [yes,NO]
Confirm this command? [yes,no]
// YES/NO
Confirm this command? [YES/no]
Confirm this command? [yes/NO]
Confirm this command? [yes/no]
// NO,YES
Confirm this command? [no,YES]
Confirm this command? [NO,yes]
Confirm this command? [no,yes]
// NO/YES
Confirm this command? [no/YES]
Confirm this command? [NO/yes]
Confirm this command? [no/yes]
// DO NOT MATCH
Confirm this command? [YES,no,cancel]
Confirm this command? [yes,NO,cancel]
Confirm this command? [yes,no,CANCEL]
Confirm this command? [YES/no/cancel]
Confirm this command? [yes/NO/cancel]
Confirm this command? [yes/no/CANCEL]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end