#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[[^][]*](*SKIP)(*FAIL)|-"
Local $sString = "abc-def]" & @CRLF & _
"Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]" & @CRLF & _
"Total Internet-Time Spent Online-Past 7 Days"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")