$re = '/[^\\\\\/:*?"<>|\r\n]+$/m';
$str = 'C:\\Program Files (x86)\\Dropbox\\Update\\1.3.547.1\\DropboxUpdateHelper.msi
C:\\test\\path\\file.name
C:\\really\\long\\file.extension1234567890
C:\\temp\\test.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);