# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])/$1$2/gm;t' <<< "<h1 id=\"anwendungsfälle-und--funktionen\">Anwendungsfälle und -funktionen</h1>
<h1 id=\"öl\">Öl</h1>"