#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])"
Local $sString = "<h1 id="anwendungsfälle-und--funktionen">Anwendungsfälle und -funktionen</h1> " & @CRLF & _
"<h1 id="öl">Öl</h1>"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)