using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G(?!^)|<h\d+\s+id="")([^""]*?)([üöä])";
string substitution = @"$1$2";
string input = @"<h1 id=""anwendungsfälle-und--funktionen"">Anwendungsfälle und -funktionen</h1>
<h1 id=""öl"">Öl</h1>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}