use strict;
my $str = '<h1 id="anwendungsfälle-und--funktionen">Anwendungsfälle und -funktionen</h1>
<h1 id="öl">Öl</h1>';
my $regex = qr/(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";