$re = '/^02.*(\d{2})(?!\1$)\d{2}$/m';
$str = '0223216582
0223216565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);