re = /(\()?(\+62|62|0)(\d{2,3})?\)?[ .-]?\d{2,4}[ .-]?\d{2,4}[ .-]?\d{2,4}/
str = 'here is my phone (0817)34567890
0817.3456.7890
0817 3456 7890
(+62) 81734567890
(+62) 817-3456-7890
+6281734567890
+62-817-3456-7890
+62817 3456 7890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end