// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\()?(\+62|62|0)(\d{2,3})?\)?[ .-]?\d{2,4}[ .-]?\d{2,4}[ .-]?\d{2,4}").unwrap();
let string = "here is my phone (0817)34567890
0817.3456.7890
0817 3456 7890
(+62) 81734567890
(+62) 817-3456-7890
+6281734567890
+62-817-3456-7890
+62817 3456 7890";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}