import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<airportCode>[A-Z0-9]{3})(?<providerCode>[A-Z0-9])(?<terminalCode>[A-Z0-9])(?<workstationCode>[A-Z0-9]{7})$";
final String string = "ABJE1CK00101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}