#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m) (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()"
Local $sString = "foobar baz (somesampletextinhere)blah(some sample text in here) and some more" & @CRLF & _
"foobar baz (some sampletextinhere) blah (some sample text in here) and some more" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)