$re = '/\babc\d+_def(\d{2})\b/';
$str = 'abc1_def23
abc10_def99
abc9_def9
eeabc1_def23
eeabc10_def99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);