$re = '/(?:ABC=(?<abc>\d+)&&DEF=(?<def>\d+))+/m';
$str = 'description=beg Area1 - ABC=704&&DEF=03||ABC=706&&DEF=04
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);