re = /(?:ABC=(?<abc>\d+)&&DEF=(?<def>\d+))+/m
str = 'description=beg Area1 - ABC=704&&DEF=03||ABC=706&&DEF=04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end