using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ID\s?:\s?(.*)\r*\n";
string input = @"ID:
Rule name: an id
Severity: Medium
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}