package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ID\s?:\s?(.*)\r*\n`)
var str = `ID:
Rule name: an id
Severity: Medium
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}