$re = '/^(?:[^{}\n]*{[^}\n]*})*[^{}\n]*$/m';
$str = '{a} {boy} lives here
{a} boy {lives} here
a {boy} lives here
a boy lives here
a boy lives here }
{{a} boy lives here}
a boy {{lives}} here
a boy {lives} here {
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);