re = /(^\+?[\d\s?]{10,15})/m
str = '004219126559874
0908312334
+421908332314
+420987654321
+420 987 654 321
+421 223 987 828
0913987654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end