re = /(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)/
str = '((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)'
subst = 'pow(\\2, \\3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result