$re = '~(*UCP)keywords/(?P<value>[\w+].+)~m';
$str = 'keywords/ءءء';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);