// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.*[\/\\](?<FileNameWithoutExtension>.*)\.(.*)$").unwrap();
let string = "\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}