import Foundation
let pattern = #"<!--.*?-->"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
blablabla
<teste>teste</teste>
etc
<!-- Assinatura principal -->
<x>mais conteúdo</x>
<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->
blablabla
<!---->
<!--
-->
<p>lorem ipsum</p>
<!-- <!-- fad ->----->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)