using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})\ \<\d+\>\ -\ .+\ \[([0-9]{2}\/(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\/[0-9]{4}:[0-9]{2}:[0-9]{2}:[0-9]{2})\ [+|-]\d\d\d\d\]\ \""(?:(PATCH|GET|POST|PUT|HEAD|DELETE|OPTIONS|CONNECT|TRACE))\ ([^\ ?]+).+\""\ 200\ \d+\ (\d+.\d+)";
string input = @"127.0.0.1 <3772> - 5a856643-2ac9-402f-83bf-fcb088513e64 [18/Dec/2018:10:42:42 -0300] ""POST /engine/task_result HTTP/1.1"" 200 4 0.663223";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}