# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$"
test_str = ("01101101\n"
"01111100\n"
"10110011\n"
"01010101\n"
"00011111\n"
"11111000\n"
"00000000\n"
"101010100\n"
"101010100000000000000000000000000000000\n\n"
"00111111\n"
"11111111\n"
"011111\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.