re = /^(\w+(\s+\w+)*),\s?(\d+)\s+-\s+([\w-\s:]+(\s+\w+)*-?[\w+\s+:;]),\s?(\w+(\s+\w+)*)\s?-?\s?(\w+(\s+\w+)*),\s?(\w{2,})$/
str = 'R dos Guajajaras, 1333 - lj-27, Barro Preto - Belo Horizonte, MG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end