#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?"
Local $sString = "DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G" & @CRLF & _
"sfasefsafes234.2,34 ML ,2 ML" & @CRLF & _
"0.5 MG/234ML" & @CRLF & _
"0.5MG23" & @CRLF & _
"0.5MCG" & @CRLF & _
"0234.2342 MCG" & @CRLF & _
"500,505,55 MCG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")