const regex = /[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+\\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\\\/?[0-9]+\\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?', 'gm')
const str = `DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G
sfasefsafes234.2,34 ML ,2 ML
0.5 MG/234ML
0.5MG23
0.5MCG
0234.2342 MCG
500,505,55 MCG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}