use strict;
my $str = '2019-05-08T20:55:04.913701+00:00 CEF: 0|CISCO|ASA||302013|Built outbound TCP connection|Low| eventId=17363056 externalId=116395008 proto=TCP
CEF:0|CISCO|ASA||302013|Built outbound TCP connection|Low| eventId=17363056 externalId=116395008 proto=TCP
';
my $regex = qr/^(.+)([A-Z]{3}:)(\s+)([A-Z0-9|=]+)(.*\S\s*?)/mp;
my $subst = '\\2\\4\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";