#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*\S\R)(\d)(\R0)$"
Local $sString = "ABC" & @CRLF & _
"5" & @CRLF & _
"0" & @CRLF & _
"gdfgdfg" & @CRLF & _
"-----------" & @CRLF & _
"GHN" & @CRLF & _
"3" & @CRLF & _
"0" & @CRLF & _
"ffffffff" & @CRLF & _
"fffff" & @CRLF & _
"ffff" & @CRLF & _
"trte" & @CRLF & _
"-------------" & @CRLF & _
"H" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"----------------"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)