use strict;
my $str = 'Dr. Doctor
Esq. Esquire
Hon. Honerable
Jr. Junior
Mr. Mister
Mrs. Misses
Ms. Miss
Messrs. Misters
Mmes. Misseses
Msgr. Monsignor
Prof. Professor
Rev. Reverend
Rt. Honorable
Sr. Senior
St. Saint';
my $regex = qr/[A-Z]([a-z]+). [A-z]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}