$re = '/^[^~]+~\s*|\s*!r\b.*/m';
$str = 'a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;