# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http:[a-z\d_.\/]*|\G(?!\A)) ([a-z\d_.\/]+)/$1$2/gu;t' <<< "Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы
в остальном тексте? http: //en. website. ru/ все ссылки с http
содержащие пробелы необходимо автоматически преобразовать в цельные ссылки
без пробелов http://en.website. ru/
"