using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:[a-z\d_./]*|\G(?!\A)) ([a-z\d_./]+)";
string substitution = @"$1$2";
string input = @"Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы
в остальном тексте? http: //en. website. ru/ все ссылки с http
содержащие пробелы необходимо автоматически преобразовать в цельные ссылки
без пробелов http://en.website. ru/
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}