import re
regex = re.compile(r"^(<[A-Za-z-]+)", flags=re.MULTILINE)
test_str = "<iframe "
subst = "$1 my-attr"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)