re = /\((?<id>\d+)\)\s*(?<text>.*?)\s*(?=$|\()/
str = '(1) Really not. (2) Uh huh. (3) Behold Prince (4) are key in his natural element, cowering at the mercy of the women in his life. (5) See me perhaps you\'d like to spout with my daughters and teach them some combination. (6) No doubt you are the best teacher, your majesty. (7) It is my daughter\'s that teach me in the languages of the modern world, for instance.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end