const regex = /^\s*(?:M(?:iss|rs?|s)|Dr|Rev|Er)\b[\s.]*/igsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:M(?:iss|rs?|s)|Dr|Rev|Er)\\b[\\s.]*', 'igsm')
const str = `Mr. Aftab
Dr . Amir
mrs . kapoor
Er. Elon Musk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}