#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?://)?(www\.)?youtu(\.be|be\.com)/(watch\?v=|embed/)?(?<id>[\w-]{11,})"
Local $sString = "https://youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"https://www.youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"https://youtu.be/q9s_9RZ6lvw" & @CRLF & _
"https://www.youtube.com/embed/q9s_9RZ6lvw" & @CRLF & _
"https://youtube.com/embed/q9s_9RZ6lvw" & @CRLF & _
"youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"www.youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"youtu.be/q9s_9RZ6lvw" & @CRLF & _
"youtube.com/embed/q9s_9RZ6lvw" & @CRLF & _
"http://youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"http://www.youtube.com/watch?v=q9s_9RZ6lvw" & @CRLF & _
"http://youtu.be/q9s_9RZ6lvw" & @CRLF & _
"http://www.youtube.com/embed/q9s_9RZ6lvw" & @CRLF & _
"http://youtube.com/embed/q9s_9RZ6lvw" & @CRLF & _
"http://youtube.com/watch?v=q9s_9RZ6lvw&rel=1" & @CRLF & _
"http://www.youtube.com/watch?v=q9s_9RZ6lvw&autoplay=1" & @CRLF & _
"http://youtu.be/q9s_9RZ6lvw?ref=0" & @CRLF & _
"http://www.youtube.com/embed/q9s_9RZ6lvw?abc=xyz" & @CRLF & _
"http://youtube.com/embed/q9s_9RZ6lvw?1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")