import Foundation
let pattern = #"^(https?://)?(www\.)?youtu(\.be|be\.com)/(watch\?v=|embed/)?(?<id>[\w-]{11,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://youtube.com/watch?v=q9s_9RZ6lvw
https://www.youtube.com/watch?v=q9s_9RZ6lvw
https://youtu.be/q9s_9RZ6lvw
https://www.youtube.com/embed/q9s_9RZ6lvw
https://youtube.com/embed/q9s_9RZ6lvw
youtube.com/watch?v=q9s_9RZ6lvw
www.youtube.com/watch?v=q9s_9RZ6lvw
youtu.be/q9s_9RZ6lvw
youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw
http://www.youtube.com/watch?v=q9s_9RZ6lvw
http://youtu.be/q9s_9RZ6lvw
http://www.youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw&rel=1
http://www.youtube.com/watch?v=q9s_9RZ6lvw&autoplay=1
http://youtu.be/q9s_9RZ6lvw?ref=0
http://www.youtube.com/embed/q9s_9RZ6lvw?abc=xyz
http://youtube.com/embed/q9s_9RZ6lvw?1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)