#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$"
Local $sString = "2-3" & @CRLF & _
"2-6" & @CRLF & _
"a-e" & @CRLF & _
"f-y" & @CRLF & _
"^-j" & @CRLF & _
"A-Z" & @CRLF & _
"A-E"
Local $sSubst = "£"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)