Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^#!(/usr)?/bin/(env )?(ba)?sh$
"
gm
Input 1
1
New
#!/bin/sh #!/bin/bash #!/usr/bin/env bash #!/usr/bin/env sh #!/usr/bin/env python #!/usr/bin/env python3