using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Exactfoobar(?:\.[a-z0-9][a-z0-9_-]*){2}(?:\.[a-zA-Z0-9][a-zA-Z0-9_-]*)+$";
string input = @"Exactfoobar.somestring.some_other-string.someStringwithCaps
There could be 4 or more fields separated by a dot
The first word should be exactly Exactfoobar.
The 2nd and 3rd word can't have caps but can have -_
The 4th word and so on can have caps with -_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}