import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Exactfoobar(?:\\.[a-z0-9][a-z0-9_-]*){2}(?:\\.[a-zA-Z0-9][a-zA-Z0-9_-]*)+$";
final String string = "Exactfoobar.somestring.some_other-string.someStringwithCaps\n\n"
+ "There could be 4 or more fields separated by a dot\n"
+ "The first word should be exactly Exactfoobar.\n"
+ "The 2nd and 3rd word can't have caps but can have -_\n"
+ "The 4th word and so on can have caps with -_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}