use strict;
my $str = 'Exactfoobar.somestring.some_other-string.someStringwithCaps
There could be 4 or more fields separated by a dot
The first word should be exactly Exactfoobar.
The 2nd and 3rd word can\'t have caps but can have -_
The 4th word and so on can have caps with -_';
my $regex = qr`^Exactfoobar(?:\.[a-z0-9][a-z0-9_-]*){2}(?:\.[a-zA-Z0-9][a-zA-Z0-9_-]*)+$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}