import re
regex = re.compile(r"^Exactfoobar(?:\.[a-z0-9][a-z0-9_-]*){2}(?:\.[a-zA-Z0-9][a-zA-Z0-9_-]*)+$", flags=re.MULTILINE)
test_str = ("Exactfoobar.somestring.some_other-string.someStringwithCaps\n\n"
"There could be 4 or more fields separated by a dot\n"
"The first word should be exactly Exactfoobar.\n"
"The 2nd and 3rd word can't have caps but can have -_\n"
"The 4th word and so on can have caps with -_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")