#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z]+\.(?:com|net|org|co)(?:\.uk)?$"
Local $sString = ".ilikestack@gmail.com" & @CRLF & _
"ilikestack@gmail.com_" & @CRLF & _
"ilikestack@gmail.com" & @CRLF & _
"ilike.stack@gmail.co.uk" & @CRLF & _
"i@1.co" & @CRLF & _
"i@1.c" & @CRLF & _
"i@1.c.a" & @CRLF & _
"i@1.1" & @CRLF & _
"i@abcabca.abcabcaabcabcaabcabca.abcabca"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")