const regex = /(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<w-block-content[\\s\\S]*?<span[\\s\\S]*?<div[\\s\\S]*?>)[\\s\\S]*?(?=<\\\/w-block-content>)', 'g')
const str = `
<w-block-content id="A">
CONTENT OF #A
<span id="B">
CONTENT OF #B
<div id="C">
<p>CONTENT OF #C</p>
</div>
CONTENT OF #B
</span>
CONTENT OF #A
</w-block-content>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}