package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|1[0-2])$`)
var str = `0
1
2
3
4
5
6
7
8
9
10
11
12
13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}