re = /(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?/m
str = 'Kraus, Fritz R., (1968) 146
Owen, David I., (2013) 1156
Dalley, Stephanie & Yoffee, Norman, (1991) 001
De Graef, (2016) p. 32 no. 9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end